12.2.15

Uva 1185 - Big Number

 In many applications very large integers numbers are required.
Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input 

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 $ \leq$ n $ \leq$ 107 on each line.

Output 

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input 

2
10
20

Sample Output 

7
19




CODE:



#include<stdio.h>
#include<math.h>

int main()
{
    double n,i,m,f=0,t;
    scanf("%lf",&t);
    while(t--){
    scanf("%lf",&n);
    {
        m=0;
        for(i=1; i<=n; i++)
        {
            m+=log10(i);
        }
        f=floor(m)+1;
        printf("%.0lf\n",f);
    }}
    return 0;
}


No comments:

Post a Comment